Remote testing with TCP samplers

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Remote testing with TCP samplers

Yuval-5
Hi,
 I'm trying to run a load test with TCP samplers using remote testing.
 Everything seems to be working fine, but when I monitored the connection
between the machines I saw that there are open connections between the
JMeter GUI and the JMeter server, but the requests to the server are
actually being sent from the machine on which the GUI is running instead of
the server.
 Is that how it's suppose to be or is it a bug?
 Thanks,
 Y.
Reply | Threaded
Open this post in threaded view
|

Re: Remote testing with TCP samplers

sebb-2-2
The test is supposed to run on the server node, so that _sounds_ like a bug.

However, since the test plan can also be run in the GUI (client) it
would be worth checking that the test is not also being run locally.
The jmeter.log files should help here.

S.
On 5/25/05, Yuval <[hidden email]> wrote:

> Hi,
>  I'm trying to run a load test with TCP samplers using remote testing.
>  Everything seems to be working fine, but when I monitored the connection
> between the machines I saw that there are open connections between the
> JMeter GUI and the JMeter server, but the requests to the server are
> actually being sent from the machine on which the GUI is running instead of
> the server.
>  Is that how it's suppose to be or is it a bug?
>  Thanks,
>  Y.
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Remote testing with TCP samplers

Yuval-5
Thanks sebb,
 It seems like my server couldn't receive any more connections so no
connections were opened from the jmeter server.
 Thanks!
 On 5/25/05, sebb <[hidden email]> wrote:

>
> The test is supposed to run on the server node, so that _sounds_ like a
> bug.
>
> However, since the test plan can also be run in the GUI (client) it
> would be worth checking that the test is not also being run locally.
> The jmeter.log files should help here.
>
> S.
> On 5/25/05, Yuval <[hidden email]> wrote:
> > Hi,
> > I'm trying to run a load test with TCP samplers using remote testing.
> > Everything seems to be working fine, but when I monitored the connection
> > between the machines I saw that there are open connections between the
> > JMeter GUI and the JMeter server, but the requests to the server are
> > actually being sent from the machine on which the GUI is running instead
> of
> > the server.
> > Is that how it's suppose to be or is it a bug?
> > Thanks,
> > Y.
> >
> >
>