Not able to record traffic in Jmeter

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Not able to record traffic in Jmeter

Pravesh Prajapati
Hi Team,
Please provide solution for below issues.
1.When i am trying to record my script in Jmeter 5.0 my application is
showing me pop-up t authorize. Now when i am authorizing the pop-up by
giving uid and pwd, then i am getting http connection error. please help me
on this(for this I am using Authorization manager in Jmeter).
Normally when i am navigation application with out jmeter it is working
fine.

2.For other application when i am trying to record script
In my application when i am clicking on one link it is navigation to 2nd
application, now in Jmeter when I am trying to record my first
application's traffic is recorded but when i click on that link and it
shows connection error, i.e my traffic is not being recorded.

Please help me on these above issue.



--
Regards,
Pravesh prajapati.
Mob:-9702600170
Reply | Threaded
Open this post in threaded view
|

Re: Not able to record traffic in Jmeter

shettyd
Hi
its hard to say without looking at your script or your setup.
Possible issues are
a. Your browser is using a configured proxy - When you are recording a
script , you are replacing the browsers proxy by JMeters so you effectively
have to configure JMeter to use the proxy the browser was originally using
https://jmeter.apache.org/usermanual/get-started.html#proxy_server .
however if your browser is using a script with multiple different proxies
then this is diffuclt to do. Its probably easier to record the browser
script and convert that into a JMeter script either directly if the
recorder supports it or manually.
b. You are using something custom (like an applet/control)
c. Your script has some exclusions that are impacting the recording (for
e.g. excluding a javascript that is relevant for SSO)
d. Something else.

regards
deepak

On Sat, Feb 23, 2019 at 11:53 PM Pravesh Prajapati <
[hidden email]> wrote:

> Hi Team,
> Please provide solution for below issues.
> 1.When i am trying to record my script in Jmeter 5.0 my application is
> showing me pop-up t authorize. Now when i am authorizing the pop-up by
> giving uid and pwd, then i am getting http connection error. please help me
> on this(for this I am using Authorization manager in Jmeter).
> Normally when i am navigation application with out jmeter it is working
> fine.
>
> 2.For other application when i am trying to record script
> In my application when i am clicking on one link it is navigation to 2nd
> application, now in Jmeter when I am trying to record my first
> application's traffic is recorded but when i click on that link and it
> shows connection error, i.e my traffic is not being recorded.
>
> Please help me on these above issue.
>
>
>
> --
> Regards,
> Pravesh prajapati.
> Mob:-9702600170
>
Reply | Threaded
Open this post in threaded view
|

Re: Not able to record traffic in Jmeter

Pravesh Prajapati
Thanks Deepak,
I will try and let you know.

Regards
Pravesh p

On Tuesday, February 26, 2019, Deepak Shetty <[hidden email]> wrote:

> Hi
> its hard to say without looking at your script or your setup.
> Possible issues are
> a. Your browser is using a configured proxy - When you are recording a
> script , you are replacing the browsers proxy by JMeters so you effectively
> have to configure JMeter to use the proxy the browser was originally using
> https://jmeter.apache.org/usermanual/get-started.html#proxy_server .
> however if your browser is using a script with multiple different proxies
> then this is diffuclt to do. Its probably easier to record the browser
> script and convert that into a JMeter script either directly if the
> recorder supports it or manually.
> b. You are using something custom (like an applet/control)
> c. Your script has some exclusions that are impacting the recording (for
> e.g. excluding a javascript that is relevant for SSO)
> d. Something else.
>
> regards
> deepak
>
> On Sat, Feb 23, 2019 at 11:53 PM Pravesh Prajapati <
> [hidden email]> wrote:
>
> > Hi Team,
> > Please provide solution for below issues.
> > 1.When i am trying to record my script in Jmeter 5.0 my application is
> > showing me pop-up t authorize. Now when i am authorizing the pop-up by
> > giving uid and pwd, then i am getting http connection error. please help
> me
> > on this(for this I am using Authorization manager in Jmeter).
> > Normally when i am navigation application with out jmeter it is working
> > fine.
> >
> > 2.For other application when i am trying to record script
> > In my application when i am clicking on one link it is navigation to 2nd
> > application, now in Jmeter when I am trying to record my first
> > application's traffic is recorded but when i click on that link and it
> > shows connection error, i.e my traffic is not being recorded.
> >
> > Please help me on these above issue.
> >
> >
> >
> > --
> > Regards,
> > Pravesh prajapati.
> > Mob:-9702600170
> >
>


--
Regards,
Pravesh prajapati.
Mob:-9702600170