JMETER throwing 400 bad request but same URl in browser is working fine

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

JMETER throwing 400 bad request but same URl in browser is working fine

UserJMeter999
400 Bad Request Issue with URL
https://maps.googleapis.com/maps/api/streetview/metadata?key=AIzaSyAhpDEvHFjzUs2zUT8rYGrGjGfX1zPZEWM&location=39.08470153808594%2C-94.5835037231445
Above URL if i hit in browser works fine but in JMETER giving 400 bad
request I tried adding Content-Type with different set as application/json
also as text/plain nothing worked Even i tried putting these 2 parameters
separately as Name and value with URL encoding selected that is also didnot
work
New key value can be used is AIzaSyAhpDEvHFjzUs2zUT8rYGrGjGfX1zPZEWM


<http://www.jmeter-archive.org/file/t344213/image436.png>



--
Sent from: http://www.jmeter-archive.org/JMeter-User-f512775.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: JMETER throwing 400 bad request but same URl in browser is working fine

Felix Schumacher

Am 18.03.19 um 17:19 schrieb UserJMeter999:

> 400 Bad Request Issue with URL
> https://maps.googleapis.com/maps/api/streetview/metadata?key=AIzaSyAhpDEvHFjzUs2zUT8rYGrGjGfX1zPZEWM&location=39.08470153808594%2C-94.5835037231445
> Above URL if i hit in browser works fine but in JMETER giving 400 bad
> request I tried adding Content-Type with different set as application/json
> also as text/plain nothing worked Even i tried putting these 2 parameters
> separately as Name and value with URL encoding selected that is also didnot
> work
> New key value can be used is AIzaSyAhpDEvHFjzUs2zUT8rYGrGjGfX1zPZEWM
>
>
> <http://www.jmeter-archive.org/file/t344213/image436.png>

In your picture you are using the parameter tab for the parameters. Try
to use the url field to specify those parameters.

Felix

>
>
>
> --
> Sent from: http://www.jmeter-archive.org/JMeter-User-f512775.html
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: JMETER throwing 400 bad request but same URl in browser is working fine

Felix Schumacher

Am 18.03.19 um 18:59 schrieb Felix Schumacher:

>
> Am 18.03.19 um 17:19 schrieb UserJMeter999:
>> 400 Bad Request Issue with URL
>> https://maps.googleapis.com/maps/api/streetview/metadata?key=AIzaSyAhpDEvHFjzUs2zUT8rYGrGjGfX1zPZEWM&location=39.08470153808594%2C-94.5835037231445 
>>
>> Above URL if i hit in browser works fine but in JMETER giving 400 bad
>> request I tried adding Content-Type with different set as
>> application/json
>> also as text/plain nothing worked Even i tried putting these 2
>> parameters
>> separately as Name and value with URL encoding selected that is also
>> didnot
>> work
>> New key value can be used is AIzaSyAhpDEvHFjzUs2zUT8rYGrGjGfX1zPZEWM
>>
>>
>> <http://www.jmeter-archive.org/file/t344213/image436.png>
>
> In your picture you are using the parameter tab for the parameters.
> Try to use the url field to specify those parameters.
I tried to reproduce your problem and the only thing that came near to
your failed sampler, was when I used
https://maps.googleapis.com/maps/... as the Path parameter. All other
combinations did work (tested on 5.1.1 -- well trunk really).

What version of JMeter are you using (plus OS and Java)?

What is the error message, google sends you?

I try to attach the test plan with the different combinations, but the
mailing list is known to strip attachements, so it may not be there. One
sampler should not work (it is named ... - broken)

Felix

>
> Felix
>
>>
>>
>>
>> --
>> Sent from: http://www.jmeter-archive.org/JMeter-User-f512775.html
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

get-parameter.jmx (25K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: JMETER throwing 400 bad request but same URl in browser is working fine

Felix Schumacher

Am 18.03.19 um 19:25 schrieb Felix Schumacher:

>
> Am 18.03.19 um 18:59 schrieb Felix Schumacher:
>>
>> Am 18.03.19 um 17:19 schrieb UserJMeter999:
>>> 400 Bad Request Issue with URL
>>> https://maps.googleapis.com/maps/api/streetview/metadata?key=AIzaSyAhpDEvHFjzUs2zUT8rYGrGjGfX1zPZEWM&location=39.08470153808594%2C-94.5835037231445 
>>>
>>> Above URL if i hit in browser works fine but in JMETER giving 400 bad
>>> request I tried adding Content-Type with different set as
>>> application/json
>>> also as text/plain nothing worked Even i tried putting these 2
>>> parameters
>>> separately as Name and value with URL encoding selected that is also
>>> didnot
>>> work
>>> New key value can be used is AIzaSyAhpDEvHFjzUs2zUT8rYGrGjGfX1zPZEWM
>>>
>>>
>>> <http://www.jmeter-archive.org/file/t344213/image436.png>
>>
>> In your picture you are using the parameter tab for the parameters.
>> Try to use the url field to specify those parameters.
>
> I tried to reproduce your problem and the only thing that came near to
> your failed sampler, was when I used
> https://maps.googleapis.com/maps/... as the Path parameter. All other
> combinations did work (tested on 5.1.1 -- well trunk really).
>
> What version of JMeter are you using (plus OS and Java)?
>
> What is the error message, google sends you?
>
> I try to attach the test plan with the different combinations, but the
> mailing list is known to strip attachements, so it may not be there.
> One sampler should not work (it is named ... - broken)

I think your problem is the ":authority" key in the header manager.
Could you try your request without it, or at least without the leading
colon?

Felix

>
> Felix
>
>>
>> Felix
>>
>>>
>>>
>>>
>>> --
>>> Sent from: http://www.jmeter-archive.org/JMeter-User-f512775.html
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: JMETER throwing 400 bad request but same URl in browser is working fine

UserJMeter999
In reply to this post by UserJMeter999
Thanks.Yes it was colon in the header name



--
Sent from: http://www.jmeter-archive.org/JMeter-User-f512775.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]