Exclude mongo-java-driver 2.11.3 jar from jmeter plugin maven build

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Exclude mongo-java-driver 2.11.3 jar from jmeter plugin maven build

Sachin Singh
 Hi All,
I am using jmeter as maven plugin using below code and wanted to use
mongodb version 3.5  but jmeter  download and uses only 2.11.3 version.
                                 <plugin>
<groupId>com.lazerycode.jmeter</groupId>
<artifactId>jmeter-maven-plugin</artifactId>
<version>2.0.3</version>
<configuration>
<jmeterExtensions>
<artifact>org.mongodb:mongo-java-driver:3.5.0</artifact>
</jmeterExtensions>
</configuration>
</plugin>

Please let me know if we have some option to exclude mongo-java-driver
2.11.3 from maven build and point jmeter to use latest given version


With Regards

Sachin
Reply | Threaded
Open this post in threaded view
|

Re: Exclude mongo-java-driver 2.11.3 jar from jmeter plugin maven build

shettyd
Hi
I dont think thats an official supported plugin.
However your question is really a Maven question (what should I do when
different libraries refer to different version of the same jars?) - see for
e.g.
http://maven.apache.org/guides/introduction/introduction-to-dependency-mechanism.html#Dependency_Management
 or https://dzone.com/articles/solving-dependency-conflicts-in-maven

regards
deeopak

On Sat, Dec 14, 2019 at 9:54 PM Sachin Singh <[hidden email]> wrote:

>  Hi All,
> I am using jmeter as maven plugin using below code and wanted to use
> mongodb version 3.5  but jmeter  download and uses only 2.11.3 version.
>                                  <plugin>
> <groupId>com.lazerycode.jmeter</groupId>
> <artifactId>jmeter-maven-plugin</artifactId>
> <version>2.0.3</version>
> <configuration>
> <jmeterExtensions>
> <artifact>org.mongodb:mongo-java-driver:3.5.0</artifact>
> </jmeterExtensions>
> </configuration>
> </plugin>
>
> Please let me know if we have some option to exclude mongo-java-driver
> 2.11.3 from maven build and point jmeter to use latest given version
>
>
> With Regards
>
> Sachin
>