Cookie Manager Question

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Cookie Manager Question

Chad La Joie-2
I'm using JMeter 2.0.3 on JDK 1.5 and I'm running in to unexpected
behavior from the cookie manager.  I have a very simple test plan.  Go
to home page, login, go to a restricted (i.e. you need to be logged in)
form.  Log in is done just by posting a user id and password with a
session cookie being set upon successful authentication.  However, the
cookie manager in my thread group does not capture this cookie, so when
I try to go the restricted form page I get an error about not having
access (which is correct).

Here's the layout of my test plan

Test Plan
 - Thread Group
   - HTTP Request defaults (has my server and protocol (HTTPS))
   - HTTP Cookie Manager
   - Simple controller
     - HTTP Request (for home page)
     - Once Only Controller
       - HTTP Request (post to log in page)
     - Loop Controller
       - HTTP Request (for getting the form)
       - Constant Timer (pause for a bit)
   - View Results Tree

I've tried moving the cookie manager around to different places and
disabling SSL on the server.  Neither made a difference.  In the results
for the HTTP Request doing the log in POST I can see the response trying
to set the cookie.  So, what am I missing here?
--
Chad La Joie             315Q St. Mary's Hall
Project Sentinel         202.687.0124


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Cookie Manager Question

sebb-2-2
Test plan looks fine.

A few suggestions:

Any messages in jmeter.log?

The most likely problem is that the cookie manager (CM) is somehow not
finding a match for the cookie domain. Or the cookie is not being
passed to the CM.

You could try enabling debug logging for the CM, but as far as I
remember it hasn't got much logging code...

Try creating your own cookie in the CM to see how it is treated. This
might give some clues as to what is going on.

If none of this works, I guess the next stage would be to update the
CM code to add some more detailed logging. Let us know if that is the
case.

S.
On 5/17/05, Chad La Joie <[hidden email]> wrote:

> I'm using JMeter 2.0.3 on JDK 1.5 and I'm running in to unexpected
> behavior from the cookie manager.  I have a very simple test plan.  Go
> to home page, login, go to a restricted (i.e. you need to be logged in)
> form.  Log in is done just by posting a user id and password with a
> session cookie being set upon successful authentication.  However, the
> cookie manager in my thread group does not capture this cookie, so when
> I try to go the restricted form page I get an error about not having
> access (which is correct).
>
> Here's the layout of my test plan
>
> Test Plan
> - Thread Group
>   - HTTP Request defaults (has my server and protocol (HTTPS))
>   - HTTP Cookie Manager
>   - Simple controller
>     - HTTP Request (for home page)
>     - Once Only Controller
>       - HTTP Request (post to log in page)
>     - Loop Controller
>       - HTTP Request (for getting the form)
>       - Constant Timer (pause for a bit)
>   - View Results Tree
>
> I've tried moving the cookie manager around to different places and
> disabling SSL on the server.  Neither made a difference.  In the results
> for the HTTP Request doing the log in POST I can see the response trying
> to set the cookie.  So, what am I missing here?
> --
> Chad La Joie             315Q St. Mary's Hall
> Project Sentinel         202.687.0124
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]